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1. Appendix: Required Spreadsheet Skills 
This appendix consists of exercises in using Microsoft Excel to perform tasks that 

are useful in the design work of this text. The exercises are step-by-step tutorials. The 
starting and ending points of each tutorial may be found in the spreadsheet titled MS 
Excel Skills.xls on the website that accompanies this text. The text will refer to these 
sections as the skills are required. You may come here as needed to work on these 
exercises. 

1.1.1. Copy transpose 
Creating a table in MS Excel such as Table1-1 from Chapter 1 is quite easy using 

the following steps.  
1. Begin by listing the entities in separate rows starting in cell A2, as shown in 

Figure 1-1.  

 
Figure 1-1: List of Entities for Toy Catapult 

2. Select the range of cells containing the row names (cells A2:A4) and hit 
<ctrl>-c (Copy). 

3. Select the first cell of the column range (cell B1). 
4. Choose menu Edit->Paste Special… to get the dialog box shown in Figure 1-2 

 
Figure 1-2: Paste Special Dialog Box 

5. Check the box labeled “Transpose” as shown in Figure 1-2. Then, click “OK”. 
The column headings should appear as shown in Figure 1-3. 
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Figure 1-3: Table with Row and Column Headings 

6. Select the entire range of cells defining the matrix (cells A1:D4). 
7. Choose menu Format->Cells… to get the dialog box shown in Figure 1-4. 

 
Figure 1-4: Menu Format Cells Alignment 

8. Choose the tab labeled “Alignment”, select “Top” from the drop-down list 
labeled “Vertical”, and check the box labeled “Wrap text” as shown in Figure 
1-4. 

9. Choose the tab labeled “Border”, click the Presets labeled “Outline” and 
“Inside”, as shown in Figure 1-5. 
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Figure 1-5: Menu Format Cells Borders 

10. Click “OK”. The matrix should appear as in Figure 1-6. 

 
Figure 1-6: Solar System Table with Formatting 

Enter the verb phrases in the appropriate cells of the matrix as shown in Table 1-1. Since 
word-wrap was enabled in step 8 above, the resulting table should be formatted as shown 
in Table 1-1. 

1.1.2. Drag and Drop (The Affinity Process Using MS Excel)  
For a small number of comments, MS Excel can be used to drag and drop 

comments into groups. Follow these steps. 
11. Open a new sheet in MS Excel. 
12. Select all cells in the sheet by clicking in the upper left corner of the sheet. 
13. Choose menu Format->Cells, click tab “Patterns”, and select a light solid 

color as background for every cell. Click “OK” to close the dialog. The sheet 
should look like Figure 1-7. 
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Figure 1-7: Blank Worksheet with Colored Cells 

14. Type or paste the customer comments into different cells in a single column of 
the spreadsheet.  

15. Select the cells with comments and change their background pattern to solid 
white, turn on word-wrap, and set their border to outline. The result should 
look something like Figure 1-8. Note that we have made columns A and C 
skinny (see the Excel help file for changing column widths) and we have 
changed the background color of column C to grey. 

 
Figure 1-8: Unordered Customer Comments in Contrasting Format 

16. Add dummy column names for columns to the right of column C. Change the 
cell formats as you wish. Figure 1-9 illustrates. 
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Figure 1-9: Unordered Customer Comments with Dummy Group Headings 
17. Take the first customer comment and drag it to the top cell of the first group. 

To move a cell, first select it, then point to its lower border, then drag the cell 
to its new location and drop it. Figure 1-10 illustrates. 

 
Figure 1-10: Creating the First Affinity Group 

18. Take the next customer comment from the unordered list and drag it to one of 
the affinity group columns. If it is like other comments in some column, drop 
it in the column in a cell below the other comments. If it is unlike the 
comments in all other columns, drop it at the top of a new column. 

19. Continue the drag and drop process until all the customer comments have 
been assigned to some affinity group column. Figure 1-11 illustrates three 
possible affinity groups that could be formed from the customer comments. 
Figure 1-12 is a zoomed-out view of a complete solution for all 37 customer 
comments. We organized the customer comments into eleven affinity groups. 
The details of the groupings cannot be seen in this figure. The details can be 
found in an appendix to Chapter 2. 
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Figure 1-11: Three Possible Affinity Groups 
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Figure 1-12: Eleven Possible Affinity Groups 

20. Once the comments have been organized into affinity groups, go through each 
group and compose a sentence that summarizes the group. Use language that 
the customer or user would use. Replace the dummy group heading with the 
summary statement. Figure 1-13 illustrates for the first five affinity groups. 

 
Figure 1-13: Affinity Group Headings 

21. Rearrange the columns so that similar columns are adjacent to each other. 
This can be done by selecting a whole column, choosing menu Edit->Cut, 
select the destination column, and choose menu Insert->Cut Cells.  

22. Group similar columns by merging the cells in row 1 and creating a heading 
for the group. Create headings for each group of columns. Figure 1-14 shows 
a partial view of the resulting hierarchy. 
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Figure 1-14: A Hierarchical Group of Affinities 

23. Transpose and reformat the summary. Figure 1-15 displays the complete 
summary of the customer comments. It is the “voice of the customer,” 
summarized. 

 
Figure 1-15: The Voice of the Customer 

 

1.1.3. Drag and drop cells 
In Chapter 2, we describe a process of organizing concepts by their affinities 

(similarities or attractions) toward each other. If each concept is captured in a cell of a 
spreadsheet, this so-called “affinity process” consists of dragging and dropping cells into 
different columns. Here, we illustrate both the affinity process and the drag and drop 
feature of MS Excel using an example from Chapter 3. In that chapter, we start with a 
general requirement for a system such as “The system shall store or accept external 
energy” and we generate a list of concept fragments that might be relevant (Figure 1-16). 
At this point, there is no order to the list. They were ideas that surfaced during a 
brainstorming session. 
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Figure 1-16. Unordered Concept Fragments 

In the following steps, we format these cells and organize them into columns of 
similar concepts. 

24. Select the entire sheet by clicking in the upper-left-most corner of the 
spreadsheet (Figure 1-17). 

 
Figure 1-17. Select Entire Sheet 

25. Using menu Format->Cells->Patterns, choose a light pastel color to serve as a 
visual background. 
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Figure 1-18. Color Background Cells 

26. Select just the cells with text and use Format->Cells->Patterns to set the color 
to white since these cells will be in the foreground. 

 
Figure 1-19. Color Foreground Cells 

27. With these same cells selected use Format->Cells->Alignment to set vertical 
alignment to “top”, set “Wrap text” to true, and use Format->Cells->Border to 
set Outline to true and Inside to true. 
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Figure 1-20. Formatted Foreground Cells 

28. Place the cursor on the hairline between column labels “A” and “B” and drag 
right until the text appearance in each line of the cells is pleasing, at least until 
whole words are not split onto multiple lines. 

 
Figure 1-21. Adjust Column Width 
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29. With the text cells selected, use menu Format->Rows->Autofit to fit the row 
height to largest number of wrapped lines in each row. 

 
Figure 1-22. Text Cells Formatted for Drag and Drop (Affinity) Exercise 
30. Select columns B-K and use Format->Column->Width to set all the column 

widths to be the same as the width of column A (15.43 in the case of Figure 
1-21). 

 
Figure 1-23. Equal Column Widths 
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31. To move a text cell, first select it, then position the cursor over one of the cell 
boundaries (top, bottom, left, or right) until the shape of the cursor changes to 
a cross made of four arrow heads. When that shape cursor appears, you may 
drag the cell to a new location. Be sure not to drop it on an existing text cell. 

 
Figure 1-24. Drag and Drop, Before and After 

32. Using drag and drop, move the text cells around so that each column contains 
similar concepts but there is something conceptually different between the 
columns. That is, the concepts in the columns have an affinity for other 
concepts in the same column. 

 
Figure 1-25. Concept Fragments Organized by Affinities 

33. Type a heading label at the top of each column to describe the affinity. Use 
cell formatting to make the heading distinguishable from the concept cells. 

 
Figure 1-26. Concept Fragments Labeled by Affinity 

1.1.4. Merge cells  
In this section, we continue the example of organizing concept fragments by 

affinity from the previous section. In Figure 1-26, we perceive a difference between 
columns B-E and columns F-H, from the perspective of the system we are developing (a 
toy catapult). The first set of columns describes concepts that might provide the external 
source of power for our catapult. The second set describes ways in which energy might 
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be stored. To group these columns into sets, we want a heading label that extends over 
multiple columns. The following steps show how to merge cells to create such labels. 

34. Select cells B1:E1. Using Format->Cells->Alignment, set Horizontal 
alignment to “Center”, Vertical alignment to “Center”, and set “Merge cells” 
to true. 

 
Figure 1-27. Merge Selected Cells 

35. With the same cells selected, use Format->Cells->Border to set Outline to true 
and use Format->Cells->Patterns to set the background color to a slightly 
darker color. Type a group label into the merged cell. 

 
Figure 1-28. Group Label Using Merged Cells 

36. Repeat these steps with cells F1:H1. 
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Figure 1-29. Second Group Label 

37. Select row 1, select Insert->Rows, and then select cells B1:H1. Repeat steps 1 
and 2 to create a label for the overall grouping. Note that we have used a bold 
font in xx to create contrast with the background color. 

 
Figure 1-30. Multi-Level Group Labels 

 

1.1.5. Reorder rows and columns of a matrix 
In working with tables and matrices it is sometimes useful to reorder the rows and 

columns. For example, Figure 1-31 displays what is called a “precedence matrix” for the 
major activities in constructing a house. The “X” entries in the matrix indicate that the 
row activity corresponding to the “X” must be completed before work on the 
corresponding column activity can begin. For example, the upper-left most “X” indicates 
that the “excavate foundation” activity (the row) must be completed before the activity 
“pour concrete footings.” The diagonal entires, where row and column are the same, are 
shaded a different color. You would never place an “X” in one of these cells. The order 
of the columns matches the order of the rows. The order mostly makes sense but there is 
a problem with listing “install roof and shingles” as the second-to-last activity. The “X”’s 
in that row indicate that many other activities, such as “install heating” and “install 
plumbing”, cannot begin until after the roof is complete. We would like to move the 
activity “install roof and shingles” so that it appears in the list before these other 
dependent activities. In fact, whenever we find an “X” lying below the diagonal, we want 
to rearrange the order so that doesn’t happen. If we change the row order, then we must 
also change the column order to match. The steps below will result in all of the “X”’s 
lying above the diagonal.  
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Excavate foundation X
Pour concrete footings X

Pour concrete foundation X
Frame walls X

Install electrical X
Install heating X

Install plumbing X
Install insulation X

Add exterior walls and siding X
Add interior walls X

Build rafters X
Install roof and shingles X X X X X X

Finish  
Figure 1-31. Precedence Matrix for House Construction 

38. Observe that the row “install roof and shingles” must be moved so that it is 
above “install electrical” since this is the column of the left-most “X” 
associated with that row. To move a row, select the whole row by clicking on 
the row number( Figure 1-32),  and hit <ctrl>x (or use Edit->Cut). 
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Figure 1-32. Select a Whole Row 

39. Select the “install electrical” row by clicking on the row number as in Figure 
1-33, 
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Figure 1-33. Prepare to Insert Cut Cells 

40. Use the menu Insert->Cut Cells, to insert the row above the selected row. 
Figure 1-34 shows the result. Note that the symmetry has been altered. The 
colored cells are no longer all on the diagonal. That is because the column 
order does not match the row order. We need to move the column “install roor 
and shingles” so that it comes just before the column “install electrical.” 

41. Select the column “install roor and shingles” by clicking on the letter in the 
column heading (Figure 1-2).  
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Figure 1-34. Select a Whole Column 

42. With the whole column selected, click <ctrl>x or use menu Edit->Cut. 
43. Select the whole column for “install electrical” by clicking on the letter in the 

column heading (Figure 1-35).  
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Figure 1-35. Ready to Insert Column of Cut Cells 

44. Use menu Insert->Cut Cells. Figure 1-36 shows the result. Observe that the 
column order matches the row order and the diagonal cells are all colored. 
Also observe that we are not done yet: there is still one “X” below the 
diagonal. The “build rafters” activity must come before the “install roof and 
shingles” activity. 
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Excavate foundation X
Pour concrete footings X

Pour concrete foundation X
Frame walls X

Install roof and shingles X X X X X X
Install electrical X

Install heating X
Install plumbing X
Install insulation X

Add exterior walls and siding X
Add interior walls X

Build rafters X
Finish  

Figure 1-36. Matrix with Reordered Rows and Columns 
45. Repeat the previous steps so that activity “build rafters” comes just before 

activity “install roof and shingles”. Be sure that the resulting column order 
matches the row order (that is, keep the colored cells on the diagonal). Figure 
1-37 shows the result. Now the precedence matrix has no entries below the 
diagonal. Such a matrix is said to be in “upper triangular form” since all of the 
entries lie in the upper triangle, above the diagonal. For a precedence matrix, 
this results in an ordering of the activities that is feasible: if the activities are 
performed in this order, no activity will have to wait for some activity that is 
further down the list. 



Getting Design Right: A Systems Approach  Required Spreadsheet Skills 

Ex
ca

va
te

 fo
un

da
tio

n

Po
ur

 c
on

cr
et

e 
fo

ot
in

gs

Po
ur

 c
on

cr
et

e 
fo

un
da

tio
n

Fr
am

e 
w

al
ls

Bu
ild

 ra
fte

rs

In
st

al
l r

oo
f a

nd
 s

hi
ng

le
s

In
st

al
l e

le
ct

ric
al

In
st

al
l h

ea
tin

g

In
st

al
l p

lu
m

bi
ng

In
st

al
l i

ns
ul

at
io

n

Ad
d 

ex
te

rio
r w

al
ls

 a
nd

 s
id

in
g

Ad
d 

in
te

rio
r w

al
ls

Fi
ni

sh

Excavate foundation X
Pour concrete footings X

Pour concrete foundation X
Frame walls X
Build rafters X

Install roof and shingles X X X X X X
Install electrical X

Install heating X
Install plumbing X
Install insulation X

Add exterior walls and siding X
Add interior walls X

Finish  
Figure 1-37. Precedence Matrix in Upper Triangular Form 

1.1.6. Sum rows or columns 
The great power of a spreadsheet program is the ability to insert formulas in cells 

that compute their values depending on values in other cells in the spreadsheet. Complex 
engineering and financial models can be constructed using this feature. Because of our 
focus on design, rather than engineering, we make only minimal use of this feature. At a 
minimum, however, we need to compute sums of numbers in matrices. 

In Figure 1-38, we display a matrix from Chapter 3, in which we have tallied the 
preferences of two parents between pairs of product objectives. For example, cell B3 
indicates that both parents prefer “make the toy fun for the child” (the row) to “make the 
toy fun for the parent” (the column).  Of course that means that the entry in cell C2 must 
be zero since it would represent the contrary preference. Similarly, cell D6 has one parent 
preferring “make the toy easy to put away” (the row) to “make the toy appealing to the 
parent” (the column). That is consistent with cell F5 which has one parent with the 
contrary preference. The cells in the upper triangular portion of the matrix are shaded 
because they can be determined automatically, once the cells in the uncolored, lower 
triangular portion have been determined. 

In summarizing the preferences, we want to compute the total number of votes 
each attribute received. That is, we want to compute the total of the tallies for each row of 
the matrix. The steps below will show how to accomplish this. 
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Figure 1-38. Tallied Preferences of Two Parents 

46. In cell J2, enter the text “=sum(B2:I2)”. The “=” sign signals to the 
spreadsheet program that this cell contains a formula. The uses a built-in 
function called “sum()”. The argument of this function is the range of cells to 
include in the sum. In this case, we want all of the cells in the second row 
from column B to columnI (“B2:I2”). Hit the enter key to enter the formula. 
Select cell J2 again. 

 
Figure 1-39. The Sum Function in a Cell Formula 

47. Observe that the result of the summation is displayed in cell J2. Observe also 
that it treated the blank in cell B2 as a zero when making the computation. 
Also observe that the formula of the currently selected cell is displayed above 
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in the formula line, after the “fx” symbol. You can edit the formula on that line 
if you want to make changes. Just remember to keep the “=” sign at 
beginning. 

48. Place the cursor over the lower right hand corner of selected cell J2. It should 
change to a simple “+” sign. Drag the corner down to cell J9 and release. 
(Alternatively, select cell J2 and choose Edit->Copy, then select cells J3:J9 
and choose Edit->Paste.) Figure 1-40 shows the result. The formula has been 
copied into each cell of the range, but with a difference. Observe in cell J3 
that the formula now refers to the cells in range B3 to I3 (recall that the 
formula for the selected cell is displayed in the formula line at the top of the 
figure). Microsoft Excel has guessed that that is the formula you want for that 
row. 

 
Figure 1-40. Dragging a Cell Formula 

49. Give the new column in the table a heading, outline the cells, and change the 
background color to suggest that this column is somewhat different than the 
other columns in the table. Figure 1-41 shows the result. 



Getting Design Right: A Systems Approach  Required Spreadsheet Skills 

(row) is preferred to 
(column)

Make the 
toy fun for 
the parent

Make the 
toy fun for 
the child

Make the 
toy 
appealing 
to the 
parent

Make the 
toy 
appealing 
to the child

Make the 
toy easy to 
put away.

Make the 
toy 
playable for 
a long time.

Make the 
toy easy to 
repair

Make the 
toy 
affordable

Preference 
Count

Make the toy fun for 
the parent

0 2 0 0 0 0 2
4

Make the toy fun for 
the child

2 2 2 2 2 2 2
14

Make the toy appealing 
to the parent

0 0 2 1 0 2 2

7
Make the toy appealing 
to the child

2 0 0 1 0 2 2

7
Make the toy easy to 
put away.

2 0 1 1 0 2 2
8

Make the toy playable 
for a long time.

2 0 2 2 2 2 2

12
Make the toy easy to 
repair

2 0 0 0 0 0 2
4

Make the toy affordable 0 0 0 0 0 0 0
0  

Figure 1-41. Tallied Preference Matrix with Row Sums 
 

1.1.7. Sort rows 
Continuing the example from the previous section, suppose we wanted to report a 

ranking of the product objectives based on the number of votes they received. Follow 
these steps. 

50. Copy the final matrix from the previous section (Figure 1-41) to a new 
worksheet but choose Edit->Paste Special and choose to paste “Values” 
(Figure 1-42). 

 
Figure 1-42. Paste Values 
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51. On this sheet, since we pasted values, column J no longer has formula cells 
that refer to columns B through I. Select columns B through I and delete them. 
The result should look likeFigure 1-43. We want to sort the rows of this new 
table  

 
Figure 1-43. Unordered Product Objectives with Preference Counts 

52. Select the entire table, A1 through B9 and choose Data->Sort from the menu. 
Use the first drop down box to pick the column to base the sort on (“Preferred 
Count” and indicate that we want to sort the rows in descending order. Since 
we included the header row of table in the selection, indicate that “Header 
row” is true. The sort dialog should look like Figure 1-44. 
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Figure 1-44. The Sort Dialog 

53. Click “OK” on the sort dialog. The table is automatically sorted (Figure 1-45). 
(row) is preferred to 

(column)
Preference 
Count

Make the toy fun for 
the child 14
Make the toy playable 
for a long time.

12
Make the toy easy to 
put away. 8
Make the toy appealing 
to the parent

7
Make the toy appealing 
to the child

7
Make the toy fun for 
the parent 4
Make the toy easy to 
repair 4
Make the toy affordable

0  
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Figure 1-45. Product Objectives Ordered By Preference Count 

1.1.8. Create charts 
Microsoft Excel provides a wide array of preformatted charts for displaying your 

data. For this section we will use competitive benchmarking data from Chapter 4. Figure 
1-46 lists customer scores for two competitive products (“Catapult Kit” and “Catapult 
Replica”) in seven product objective categories ranging from “visual appeal” to 
“affordability.” All the scores are normalized to lie between 1 and 5. We would like to 
display these data in a chart. 

In the language of MS Excel charts, the number in each cell is a “data point” and 
each column of numbers is a “data series”.  

 
Figure 1-46. Customer Attribute Scores for Two Benchmarked Products 
54. The row headers are quite descriptive but they are too long to serve well as 

labels in a chart. Create a simpler set of row labels off to the side (Figure 
1-47). 
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Figure 1-47. Simplified Row Headers 

55. Select the entire table, including heading rows and columns (cells A1 through 
C8). 

56. Choose menu Insert->Chart to launch the chart wizard (Figure 1-48) 

 
Figure 1-48. Chart Wizard: Choose Chart Type 
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57. As shown in Figure 1-48, choose the Radar chart type and the lines only sub-
type. Click Next. 

 
Figure 1-49. Chart Wizard: Data Source 

58. Observe that the range A1 to C8 is the source data for the chart and that MS 
Excel has correctly deduced that our data series are in columns. Click the 
Series tab of this Wizard step. Figure 1-50 results. 
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Figure 1-50. Chart Wizard: Series Detail 

59. Observe that MS Excel has correctly discovered our two data series and 
located the name of the series in row 1 and the values in rows 2 through 8. For 
the X-axis labels it picked column A but, as you recall, these heading are quite 
verbose. We will change that choice. Click the spreadsheet symbol as shown 
in Figure 1-50. 
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Figure 1-51. Chart Wizard: Selection Tool 

60. Select cells E2 through E8, which have the simplified row headings. Click the 
“finish selection”  button in the wizard as shown in Figure 1-52.  

 
Figure 1-52. Chart Wizard: Finish Selection Button 

61. The Category X Labels will now be taken from cells E2 to E8 as shown in 
Figure 1-53. 
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Figure 1-53. Chart Wizard: Corrected Series Detail 

62. Click Next, as shown in Figure 1-53. Enter a suitable title for the Chart Title 
(Figure 1-54). 
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Figure 1-54. Chart Wizard: Titles 

63. On the legend tab of this wizard step, set “bottom” to true. This places the 
legend under the chart (Figure 1-55 

 
Figure 1-55. Chart Wizard: Legend 

64. Click “Finish”. Figure 1-56 shows the initial rendering of the chart. It is too 
small and the data series are hard to see. We will improve the formatting. 
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Benchmarking Comparison of Competitor's Toys

0

5
Visual appeal

Performance

Safety

ReliabilityEase of repair

Ease of storage

Affordability

Catapult Kit Catapult Replica
 

Figure 1-56. Initial Chart Rendering 
65. Drag the lower right corner of the chart to enlarge it. Then select one of the 

data series by clicking on one of the lines connecting the datapoints, as shown 
in Figure 1-57. 
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Figure 1-57. Selected Chart Data Series 
66. Right-click on the data series and select “Format data series” from the pop-up 

menu, as shown in Figure 1-58. 

 
Figure 1-58. Pop-up Menu for Data Series 

67. In the dialog box that appears (Figure 1-59), choose a bold color and a thick 
line weight, as shown. 

 
Figure 1-59. Format Data Series 

68. Click “OK” and then repeat the process for the other data series, choosing a 
different bold color. Figure 1-60 is the resulting chart. 
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Benchmarking Comparison of Competitor's 
Toys
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Figure 1-60. Radar Chart of Benchmarking Data 
69. Other chart types are possible. Copy the chart to a new location. Then right-

click the chart and select “Chart Type” from the pop-up menu (Figure 1-61). 

 
Figure 1-61. Chart Popup Menu 

70. Select the “Column” type of chart and click “OK”. Figure 1-62 results. Which 
chart conveys the data best to your audience? That is for you and your 
audience to decide. 
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Figure 1-62. Column Chart Type 
 

1.1.9. Use lookup formulas 
It is often useful in MS Excel to create formulas that get their values by looking 

up in a table for some matching name or number. We use that feature when we introduce 
project scheduling in Chapter 7. In that case, the reference table is a list of activities, 
giving the name of the activity, the duration in hours, how many hours have been 
completed and how many hours remain to be completed (Figure 1-63). Each activity has 
been given a unique number, such as A.01, and the table is sorted alphabetically by these 
activity numbers. 
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Figure 1-63. Reference Table Describing Activities 

Also in Chapter 7 we describe a process by which we can assign start times to 
each activity so that the overall project is finished as quickly as possible. For the example 
in Chapter 7, that led to the schedule of activity start times shown in Figure 1-64. Not all 
activities can start at once because of precedence relationships (for example, you cannot 
test a subsystem until you have first built it). 
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Figure 1-64. Schedule of Activity Start Times 

Now, what we want to do is to compute the finish times of each activity and to 
attach the activity names to the schedule of start times. This would be an easy matter of 
copying data from the reference table (Figure 1-63), except that the activities in the 
schedule are ordered differently. One solution would be to sort the schedule in Figure 
1-64 so that the activity numbers are in alphabetical order to match the reference table. 
Let us say, however, that we have good reason not to change the order of Figure 1-64. 
The following steps show how to use table lookups to get all the data we need. 

71. Select all the cells of the reference table except the heading and the total rows. 
That is, select cells A2 to F36. 

72. Choose menu Insert->Name->Define. The dialog for defining names for cell 
ranges should appear (Figure 1-65). 
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Figure 1-65. Define Cell Range Name Dialog 

73. Observe that the cell range is A2 to F36, as desired but the default name for 
this range, “Activity_Number”, is not descriptive of the contents. Change the 
name to “ActivityTable” and then click “Add”. Then click “OK”. We can now 
refer to this collection of cells by the name “ActivityTable” instead of having 
to remember the range as “A2:F36”. 

74. In cell C3 of the schedule spreadsheet, enter the formula 
“=Vlookup(A3,ActivityTable,5)”. This instructs the spreadsheet program to 
take the contents of cell A3, currrently “A.01” and find the matching row ( a 
“vertical lookup”) in the ActivityTable cell range, and return the value found 
in the fifth column. The fifth column of the ActivityTable corresponds to the 
“Work Completed” value. 

 
Figure 1-66. Look up “Work Completed” Entry for Activity A.01 

75. Observe that the value returned in cell C3, zero, does not appear to be correct. 
It should be 0.5 (see cell E2 in Figure 1-63). The problem is that the cell 
format in column C is not set to display decimal fractions. Use Format->Cells-
>Number to set the number to one decimal place. 

76. Add heading labels to cells C1 and D1, and enter the formula 
“=vlookup(A3,ActivityTable,6) into cell D3, as shown in Figure 1-67. 
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Figure 1-67. Look up "Work Remaining" Entry for Activity A.01 

77. Add a heading label in cell E1 and add a formula to cell E3 to compute the 
finish time of the activity. The finish time is the start time plus the work 
completed plus the work remaining. So, enter the formula “=sum(B3:D3).” 
Figure 1-68 illustrates. 

 
Figure 1-68. Compute Finish Time 

78. Add a heading label in cell F1 and add a formula to cell F3 to look up the 
ActivityName of the activity. The formula is “=vlookup(A3,ActivityTable,2)” 
since the ActivityName is the second column of the ActivityTable. Figure 
1-69 shows the result. 

 
Figure 1-69. Look up "ActivityName" Entry for Activity A.01 

79. Copy cells B3:F3 down to fill out the table. Figure 1-70 is the result. 
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Figure 1-70. Completed Schedule

 

1.1.10. Display Gantt chart 
In this section, we continue the example from the previous section and show how 

to display the completed schedule (Figure 1-70) as a Gantt chart.  

Gantt charts are not one of the chart types supported by MS Excel. However, 
there is a simple trick that can be employed to use the stacked bar chart in MS Excel to 
display Gantt charts. We describe the trick briefly here. Further help can be found using 
“Microsoft Office Online.” The steps to create a Gantt chart from Figure 1-70 are as 
follows: 
Select cells B3:D37 in Figure 1-70. 

80. Click the Chart Wizard on the MS Excel toolbar. 
81. Select the Bar chart type and the Stacked Bar chart sub-type. 
82. Click “Next” and then click the “Series” tab. 
83. For the category (X) axis labels, select range F3:F37. 
84. For the name of Series2, select C1. 
85. For the name of Series3, select D1. 
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86. Click “Next”. 
87. On the titles tab, enter a chart title such as “Gantt Chart of Toy Catapult 

Design, Build, and Test” 
88. On the Gridlines tab, select Minor gridlines for the category (X) axis. 
89. On the Legend tab, select “Bottom” placement for the legend. 
90. Click “Finish”. 
91. After the chart appears, click one of the horizontal bars representing Series1. 
92. Right click the same bar and choose “Format Data Series” from the popup 

menu. 
93. On the Patterns tab, select “None” for Border and “Node” for area. 
94. Click “OK”. This makes Series1 disappear. 
95. Right click the vertical axis and choose “Format axis” from the popup menu. 
96. On the scale tab, set the “Number of categories between tickmark labels” to 1 

and check the box for “Categories in reverse order”. 
97. Select the text “Series1” in the legend and delete it. 
98. Finish formatting the chart using standard techniques (adjust font sizes, clear 

background color, etc.). Figure 1-71 is the final result. 

The trick is to make Series1 (representing the start times) disappear, leaving the 
remaining stacked bars visible starting at the appropriate start times against the horizontal 
axis.  

Gantt Chart of Toy Catapult Design, Build, and Test
0 1 2 3 4 5 6 7 8 9

Develop Subsystem Requirements
Design Projectile Launch System

Build Projectile Launch System
Test Projectile Launch System
Design Energy Storage System

Build Energy Storage System
Test Energy Storage System

Design Projectile Containment System
Build Projectile Containment System
Test Projectile Containment System

Design Lock and Trigger System
Build Lock and Trigger System
Test Lock and Trigger System

Design Body (Enclosure System)
Integrate Launch and Storage Systems

Integrate Launch, Storage and Containment Systems
Maximum launch velocity

Maximum mass launch capability
Build Body (Enclosure System)
Test Body (Enclosure System)

Integrate Working System
Test Procedure: Child fails to arm toy.

Test Procedure: Child releases armed toy near face of self or another child
Test Procedure: Child aims projectile at eyes of self or of another child

Test Procedure: Child plays with toy
Test Procedure: Child uses pet rodent as projectile 

Test Procedure: The child drops or throws the toy.
Storage volume

Mean cycles to failure
Breaking force of critical components

Repair part cost
Tensile strength of home-applied adhesive bond

Time for disassembly and reassembly
Material cost

Time to manufacture

Hours Required

Work Completed Work Remaining  
Figure 1-71: Gantt Chart of Toy Catapult Design, Build, and Test 
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